Fire in Distribution Center in Finland

Incident Report for Orbyt

Resolved

No letters/documents where affected by the fire. There may be small delays in mail delivery in Orivede and Ruovede for the rest of the week.
Posted Jun 12, 2024 - 13:12 CEST

Investigating

There has been a fire in a distribution center in Orivesi. Posti is currently investigating what documents was affected by the fire, and will reach out to affected partners/customer.

More information:
https://www.posti.fi/fi/asiakastuki/tiedotteet/d/2040612_oriveden_tulipalon_vaikutukset
https://www.posti.fi/en/customer-support/news-releases
Posted Jun 12, 2024 - 09:53 CEST
This incident affected: Print (Print Finland).